Kismet Wireless

Kismet Forums

 

Posted by:markojic
Subject:ERROR: Failed to read a packet from wlan1. The interface is no longer up.
Date:16:19:03 07/07/2017

> > I've realized that I am not facing the issue on the first run of the Kismet. If I close it down, and run it again, then the error appears. The solution is to unplug/plug in the WiFi USB adapter. Somehow wlan1 stay in monitor mode, is this normal behavior?
>
> Most likely you've left networkmanager running - kali has it running by default, and networkmanager will change the type of interfaces and bring them up/down and mess with vifs.
>
> Simplest route is to just disable network manager - sudo service networkmanager stop, or something similar depending if Kali capitalizes it. A less simple solution is to figure out what networkmanager version you have installed and what you need to do to tell it to ignore your wifi interface.
>
> The git-master development kismet contains code to communicate with networkmanager and tell it to ignore the primary and vif interfaces; when that is done it will unsubscribe the interface from nm automatically.

Hm, I think I have found a solution. By editing /etc/network/interfaces and putting this line:

iface wlan1 inet static

I have disabled Network Manager for this specific interface. Regarding the nature of my project, if I kill NM completely, I will not be able to control it remotely, therefore I had to unmanage only specific interface (wlan1). No more error. Thanks for the support!


Reply to this message